NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-21667 — @soketi/soketi

HIGHFix: soketi/soketi@4b12efe

CVE-2022-21667 is a high-severity (CVSS 7.5) CWE-755 vulnerability in @soketi/soketi. A fix is available for @soketi/soketi — see the affected versions and patch details below.

Denial of Service in soketi

Also known asGHSA-86ch-6w7v-v6xf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-21667.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.41%0.98%1.55%2.12%0.9%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@soketi/soketinpm
3Kdownloads / week

Description

Impact

What kind of vulnerability is it? Who is impacted?

There was a wrong behavior when reading POST requests, making the server crash if it couldn't read the body. In case a POST request was sent to any endpoint of the server with an empty body, even unauthenticated with the Pusher Protocol, it would simply just crash the server for trying to send a response after the request closed.

All users that run the server are affected by it and it's highly recommended to upgrade to the latest patch.

Patches

Has the problem been patched? What versions should users upgrade to?

Updating to at least 0.24.1 or the latest version.

Workarounds

Is there a way for users to fix or remediate the vulnerability without upgrading?

No. Upgrading is the only solution.

References

Are there any links users can visit to find out more?

https://github.com/soketi/soketi/releases/tag/0.24.1

For more information

If you have any questions or comments about this advisory:

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@soketi/soketiall versions0.24.1npm install @soketi/soketi@0.24.1

Affected Products

1 product · 1 configurations
Application
soketisoketi_project
< 0.24.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @soketi/soketi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @soketi/soketi to 0.24.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21667 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact _What kind of vulnerability is it? Who is impacted?_ There was a wrong behavior when reading POST requests, making the server crash if it couldn't read the body. In case a POST request was sent to any endpoint of the server with an empty body, **even unauthenticated with the Pusher Protocol**, it would simply just crash the server for trying to send a response after the request closed. All users that run the server are affected by it and it's highly recommended to upgrade to the latest patch. ### Patches _Has the problem been patched? What versions should users upgrade to?_ Upda
O3 Security · Impact-Aware SCA

Is CVE-2022-21667 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-21667: @soketi/soketi — Fixed in 0.24.1