NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2022-21223 — cocoapods-downloader

HIGHFix: CocoaPods/cocoapods-downloader#127

CVE-2022-21223 is a high-severity (CVSS 8.1) CWE-88 vulnerability in cocoapods-downloader. A fix is available for cocoapods-downloader — see the affected versions and patch details below.

Command Injection

Also known asGHSA-g397-v4w5-4m79SNYK-RUBY-COCOAPODSDOWNLOADER-2414280
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs77th percentile — riskier than 77% of all scored CVEsHighest risk
0.25%0.93%1.60%2.28%0.8%1.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎cocoapods-downloader

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

The package cocoapods-downloader before 1.6.2 are vulnerable to Command Injection via hg argument injection. When calling the download function (when using hg), the url (and/or revision, tag, branch) is passed to the hg clone command in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemscocoapods-downloaderall versions1.6.2bundle update cocoapods-downloader --conservative

Affected Products

1 product · 1 configurations
Application
cocoapods-downloadercocoapods
< 1.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cocoapods-downloader, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cocoapods-downloader to 1.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21223 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The package cocoapods-downloader before 1.6.2 are vulnerable to Command Injection via hg argument injection. When calling the download function (when using hg), the url (and/or revision, tag, branch) is passed to the hg clone command in a way that additional flags can be set. The additional flags can be used to perform a command injection.
O3 Security · Impact-Aware SCA

Is CVE-2022-21223 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2022-21223: cocoapods — Fixed in 1.6.2