NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-21190 — convict

HIGHFix: mozilla/node-convict@1ea0ab1

CVE-2022-21190 is a high-severity (CVSS 7.5) CWE-1321 vulnerability in convict. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for convict — see the affected versions and patch details below.

Prototype Pollution

Also known asGHSA-jjf5-wx3j-3fv7SNYK-JS-CONVICT-2774757
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 15, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk+0.06%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.00%1.66%3.31%4.97%0.7%4.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

926other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
convictnpm
1.3Mdownloads / week

Description

This affects the package convict before 6.2.3. This is a bypass of CVE-2022-22143. The fix introduced, relies on the startsWith method and does not prevent the vulnerability: before splitting the path, it checks if it starts with proto or this.constructor.prototype. To bypass this check it's possible to prepend the dangerous paths with any string value followed by a dot, like for example foo.proto or foo.this.constructor.prototype.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmconvictall versions6.2.3npm install convict@6.2.3

Affected Products

1 product · 1 configurations
Application
convictmozilla
< 6.2.3
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for convict, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update convict to 6.2.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21190 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

This affects the package convict before 6.2.3. This is a bypass of [CVE-2022-22143](https://security.snyk.io/vuln/SNYK-JS-CONVICT-2340604). The [fix](https://github.com/mozilla/node-convict/commit/3b86be087d8f14681a9c889d45da7fe3ad9cd880) introduced, relies on the startsWith method and does not prevent the vulnerability: before splitting the path, it checks if it starts with __proto__ or this.constructor.prototype. To bypass this check it's possible to prepend the dangerous paths with any string value followed by a dot, like for example foo.__proto__ or foo.this.constructor.prototype.
O3 Security · Impact-Aware SCA

Is CVE-2022-21190 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-21190: convict — Fixed in 6.2.3