CVE-2022-21189 is a high-severity (CVSS 7.3) CWE-1321 vulnerability in dexie. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for dexie — see the affected versions and patch details below.
Prototype Pollution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
dexienpmDescription
Dexie is a minimalistic wrapper for IndexedDB. The package dexie before 3.2.2, from 4.0.0-alpha.1 and before 4.0.0-alpha.3 are vulnerable to Prototype Pollution in the Dexie.setByKeyPath(obj, keyPath, value) function which does not properly check the keys being set (like proto or constructor). This can allow an attacker to add/modify properties of the Object.prototype leading to prototype pollution vulnerability. Note: This vulnerability can occur in multiple ways, for example when modifying a collection with untrusted user input.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | dexie | all versions | 3.2.2npm install dexie@3.2.2 |
| 📦npm | dexie | ≥ 4.0.0-alpha.1&&< 4.0.0-alpha.3 | 4.0.0-alpha.3npm install dexie@4.0.0-alpha.3 |
Affected Products
dexiedexieResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dexie, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update dexie to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21189 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2022-21189 in your dependencies?
Find it across npm, including transitive dependencies.