NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2022-21187 — libvcs

HIGHFix: vcs-python/libvcs#306

CVE-2022-21187 is a high-severity (CVSS 8.1) CWE-88 vulnerability in libvcs. A fix is available for libvcs — see the affected versions and patch details below.

Command Injection

Also known asGHSA-mv2w-4jqc-6fg4PYSEC-2022-163PYSEC-2026-563SNYK-PYTHON-LIBVCS-2421204
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs89th percentile — riskier than 89% of all scored CVEsHighest risk
0.54%1.85%3.17%4.48%1.3%3.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍libvcs🐍vcspull

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIlibvcsall versions0.11.1pip install --upgrade 'libvcs==0.11.1'
🐍PyPIvcspullall versions1.11.1pip install --upgrade 'vcspull==1.11.1'

Affected Products

1 product · 1 configurations
Application
libvcslibvcs_project
< 0.11.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for libvcs, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update libvcs to 0.11.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21187 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.
O3 Security · Impact-Aware SCA

Is CVE-2022-21187 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-21187: libvcs — Fixed in 0.11.1