NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2022-21169 — express-xss-sanitizer

HIGHFix: AhmedAdelFahim/express-xss-sanitizer@3bf8aaa

CVE-2022-21169 is a high-severity (CVSS 7.3) CWE-1321 vulnerability in express-xss-sanitizer. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for express-xss-sanitizer — see the affected versions and patch details below.

Prototype Pollution

Also known asGHSA-grjp-4jmr-mjcw
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-21169.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.49%0.97%1.45%0.5%1.0%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

11other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
express-xss-sanitizernpm
26Kdownloads / week

Description

The package express-xss-sanitizer before 1.1.3 are vulnerable to Prototype Pollution via the allowedTags attribute, allowing the attacker to bypass xss sanitization.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmexpress-xss-sanitizerall versions1.1.3npm install express-xss-sanitizer@1.1.3

Affected Products

1 product · 1 configurations
Application
express xss sanitizerexpress_xss_sanitizer_project
< 1.1.3
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for express-xss-sanitizer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update express-xss-sanitizer to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-21169 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The package express-xss-sanitizer before 1.1.3 are vulnerable to Prototype Pollution via the allowedTags attribute, allowing the attacker to bypass xss sanitization.
O3 Security · Impact-Aware SCA

Is CVE-2022-21169 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-21169: express-xss-sanitizer XSS — Fixed in 1.1.3