NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
HIGH severity

CVE-2022-2097 — openssl-src

HIGH

CVE-2022-2097 is a high-severity (CVSS 7.5) Broken Cryptographic Algorithm vulnerability in openssl-src. A fix is available for openssl-src — see the affected versions and patch details below.

AES OCB fails to encrypt some bytes

Also known asGHSA-3wx7-46ch-7rq2RUSTSEC-2022-0032
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-2097.

EPSS Exploitation Probability

via FIRST.org ↗
4.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs92th percentile — riskier than 92% of all scored CVEsHighest risk
0.00%2.09%4.18%6.27%0.3%4.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🦀openssl-src🦀openssl-src

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

AES OCB mode for 32-bit x86 platforms using the AES-NI assembly optimised implementation will not encrypt the entirety of the data under some circumstances. This could reveal sixteen bytes of data that was preexisting in the memory that wasn't written. In the special case of "in place" encryption, sixteen bytes of the plaintext would be revealed. Since OpenSSL does not support OCB based cipher suites for TLS and DTLS, they are both unaffected. Fixed in OpenSSL 3.0.5 (Affected 3.0.0-3.0.4). Fixed in OpenSSL 1.1.1q (Affected 1.1.1-1.1.1p).

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.ioopenssl-srcall versions111.22.0cargo update -p openssl-src --precise 111.22.0
🦀crates.ioopenssl-src≥ 300.0.0&&< 300.0.9300.0.9cargo update -p openssl-src --precise 300.0.9

Affected Products

11 products · 17 configurations
OS
debian linuxdebian
2 versions
10.011.0
OS
fedorafedoraproject
2 versions
3536
Application
active iq unified managernetapp
all
Application
clustered data ontap antivirus connectornetapp
all
OS
h300s firmwarenetapp
all
OS
h410c firmwarenetapp
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openssl-src, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openssl-src to 111.22.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2097 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat Enterprise Linux 6 and Red Hat Enterprise Linux 7 ship OpenSSL 1.0 which does not contain the incorrect assembly code (introduced upstream with commit bd30091). Similarly, the versions of `shim` as shipped with Red Hat Enterprise Linux 8 and 9 are not affected by this issue as they bundle openssl-1.0.2j.

ProductFixed inAdvisory
Red Hat Enterprise Linux 8openssl-1:1.1.1k-7.el8_6RHSA-2022:5818
Red Hat Enterprise Linux 9openssl-1:3.0.1-41.el9_0RHSA-2022:6224

Frequently Asked Questions

AES OCB mode for 32-bit x86 platforms using the AES-NI assembly optimised implementation will not encrypt the entirety of the data under some circumstances. This could reveal sixteen bytes of data that was preexisting in the memory that wasn't written. In the special case of "in place" encryption, sixteen bytes of the plaintext would be revealed. Since OpenSSL does not support OCB based cipher suites for TLS and DTLS, they are both unaffected. Fixed in OpenSSL 3.0.5 (Affected 3.0.0-3.0.4). Fixed in OpenSSL 1.1.1q (Affected 1.1.1-1.1.1p).
O3 Security · Impact-Aware SCA

Is CVE-2022-2097 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2022-2097: openssl-src — Fixed in 111.22.0