CVE-2022-4304 — openssl-src
MEDIUMCVE-2022-4304 is a medium-severity (CVSS 5.9) CWE-203 vulnerability in openssl-src. EPSS puts its 30-day exploitation probability at 23.5% (98th percentile). A fix is available for openssl-src — see the affected versions and patch details below.
Timing Oracle in RSA Decryption
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-4304.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
openssl-src🦀openssl-srcReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
A timing based side channel exists in the OpenSSL RSA Decryption implementation which could be sufficient to recover a plaintext across a network in a Bleichenbacher style attack. To achieve a successful decryption an attacker would have to be able to send a very large number of trial messages for decryption. The vulnerability affects all RSA padding modes: PKCS#1 v1.5, RSA-OEAP and RSASVE.
For example, in a TLS connection, RSA is commonly used by a client to send an encrypted pre-master secret to the server. An attacker that had observed a genuine connection between a client and a server could use this flaw to send trial messages to the server and record the time taken to process them. After a sufficiently large number of messages the attacker could recover the pre-master secret used for the original connection and thus be able to decrypt the application data sent over that connection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | openssl-src | all versions | 111.25.0cargo update -p openssl-src --precise 111.25.0 |
| 🦀crates.io | openssl-src | ≥ 300.0.0&&< 300.0.12 | 300.0.12cargo update -p openssl-src --precise 300.0.12 |
Affected Products
opensslopensslendpoint securitystormshieldsslvpnstormshieldstormshield network securitystormshieldDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openssl-src, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openssl-src to 111.25.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-4304 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| JBCS httpd 2.4.51.sp2 | openssl | RHSA-2023:3355 |
| JBoss Core Services for RHEL 8 | jbcs-httpd24-openssl-1:1.1.1k-14.el8jbcs | RHSA-2023:3354 |
| Red Hat Enterprise Linux 8 | edk2-0:20220126gitbb1bba3d77-4.el8 | RHSA-2023:2932 |
| Red Hat Enterprise Linux 8 | openssl-1:1.1.1k-9.el8_7 | RHSA-2023:1405 |
| Red Hat Enterprise Linux 8.6 Extended Update Support | edk2-0:20220126gitbb1bba3d77-2.el8_6.1 | RHSA-2023:4128 |
| Red Hat Enterprise Linux 8.6 Extended Update Support | openssl-1:1.1.1k-9.el8_6 | RHSA-2023:3408 |
| Red Hat Enterprise Linux 9 | openssl-1:3.0.1-47.el9_1 | RHSA-2023:0946 |
| Red Hat Enterprise Linux 9 | edk2-0:20221207gitfff6d81270b5-9.el9_2 | RHSA-2023:2165 |
Frequently Asked Questions
Is CVE-2022-4304 in your dependencies?
Find it across crates.io, including transitive dependencies.