NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2022-2064 — nocodb

CRITICALFix: nocodb/nocodb@c9b5111

CVE-2022-2064 is a critical-severity (CVSS 9.1) CWE-613 vulnerability in nocodb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nocodb — see the affected versions and patch details below.

Insufficient Session Expiration in nocodb/nocodb

Also known asGHSA-6293-2vg2-pmp5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk+0.02%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.74%0.3%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
nocodbnpm
13Kdownloads / week

Description

Insufficient Session Expiration in GitHub repository nocodb/nocodb prior to 0.91.7+.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnocodball versions0.91.9npm install nocodb@0.91.9

Affected Products

1 product · 1 configurations
Application
nocodbnocodb
< 0.91.7
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nocodb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nocodb to 0.91.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2064 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Insufficient Session Expiration in GitHub repository nocodb/nocodb prior to 0.91.7+.
O3 Security · Impact-Aware SCA

Is CVE-2022-2064 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-2064: nocodb — Fixed in 0.91.9