NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2022-1571 — facturascripts

CRITICALFix: neorazorx/facturascripts@482c5a8

CVE-2022-1571 is a critical-severity (CVSS 9.9) Cross-site Scripting (XSS) vulnerability in facturascripts/facturascripts. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for facturascripts/facturascripts — see the affected versions and patch details below.

Cross-site scripting - Reflected in Create Subaccount in neorazorx/facturascripts

Also known asGHSA-m8gv-gvhf-7rhp
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs59th percentile — riskier than 59% of all scored CVEsHighest risk
0.00%0.46%0.91%1.37%0.3%0.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘facturascripts/facturascripts

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

FacturaScripts versions 2022.06 and prior are vulnerable to reflected cross-site scripting attacks. This vulnerability can use arbitrarily executed javascript code to steal users' cookies, perform HTTP request, get content of same origin page, etc. A fix is available on the master branch of the GitHub repository and anticipated to be part of version 2022.07.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistfacturascripts/facturascriptsall versions2022.07composer require facturascripts/facturascripts:^2022.07

Affected Products

1 product · 1 configurations
Application
facturascriptsfacturascripts
< 2022.07
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for facturascripts/facturascripts, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update facturascripts/facturascripts to 2022.07 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1571 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

FacturaScripts versions 2022.06 and prior are vulnerable to reflected cross-site scripting attacks. This vulnerability can use arbitrarily executed javascript code to steal users' cookies, perform HTTP request, get content of `same origin` page, etc. A fix is available on the `master` branch of the GitHub repository and anticipated to be part of version 2022.07.
O3 Security · Impact-Aware SCA

Is CVE-2022-1571 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-1571: facturascripts XSS — Fixed in 2022.07