CVE-2026-27964 is a low-severity (CVSS 3.9) Cross-site Scripting (XSS) vulnerability in facturascripts/facturascripts. A fix is available for facturascripts/facturascripts — see the affected versions and patch details below.
FacturaScripts: Reflected Cross-Site Scripting (XSS) via Cookie Manipulation
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-27964.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
facturascripts/facturascripts🐘facturascripts/facturascriptsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Summary
A Reflected Cross-Site Scripting (XSS) vulnerability exists in the fsNick cookie parameter. The application reflects the cookie's value directly into the HTML without sanitization.
Details
The fsNick cookie is rendered into the DOM without encoding. While the server does reject the modified session and forces a logout, the HTML containing the payload reaches the browser first. This lets the script execute immediately upon load, effectively beating the redirect.
PoC
-
Log in to the application with any valid account.
<img width="2078" height="302" alt="image" src="https://github.com/user-attachments/assets/d8a9a779-44e0-4a3e-839f-0a031868fbd5" /> -
Capture any the GET request .
<img width="1267" height="276" alt="image" src="https://github.com/user-attachments/assets/22e43f73-4f86-4cab-a074-7aba584a71ac" /> -
Modify the value of "fsNick" with the following JavaScript:
<script>alert(window.origin)</script> -
Send the modified request.
<img width="1569" height="319" alt="image" src="https://github.com/user-attachments/assets/ade88db1-aadc-4c50-9e02-d09888067e98" /> -
Result
<img width="1217" height="771" alt="image" src="https://github.com/user-attachments/assets/5858fe9f-127a-4845-b484-5a7ef4ae2cb4" />
Impact
The payload executes before the session ends, which could potentially allow for a single unauthorized action before the logout.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | facturascripts/facturascripts | all versions | 2025.8composer require facturascripts/facturascripts:^2025.8 |
| 🐘Packagist | facturascripts/facturascripts | ≥ 2025.11&&< 2025.81 | 2025.81composer require facturascripts/facturascripts:^2025.81 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for facturascripts/facturascripts, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update facturascripts/facturascripts to 2025.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-27964 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2026-27964 in your dependencies?
Find it across Packagist, including transitive dependencies.