NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-1554 — scout-browser

MEDIUMFix: clinical-genomics/scout@952a2e2

CVE-2022-1554 is a medium-severity (CVSS 6.8) CWE-36 vulnerability in scout-browser. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for scout-browser — see the affected versions and patch details below.

Path Traversal due to `send_file` call in clinical-genomics/scout

Also known asGHSA-694v-63fq-fmr4PYSEC-2026-749
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.11%0.70%1.28%1.87%0.6%1.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍scout-browser

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Scout is a Variant Call Format (VCF) visualization interface. The Pypi package scout-browser is vulnerable to path traversal due to send_file call in versions prior to 4.52.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIscout-browserall versions4.52pip install --upgrade 'scout-browser==4.52'

Affected Products

1 product · 1 configurations
Application
scoutclinical-genomics
< 4.52
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for scout-browser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update scout-browser to 4.52 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1554 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Scout is a Variant Call Format (VCF) visualization interface. The Pypi package `scout-browser` is vulnerable to path traversal due to `send_file` call in versions prior to 4.52.
O3 Security · Impact-Aware SCA

Is CVE-2022-1554 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-1554: scout-browser — Fixed in 4.52