NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2022-1227 — podman

HIGHFix: containers/podman#13862

CVE-2022-1227 is a high-severity (CVSS 8.8) CWE-281 vulnerability in github.com/containers/podman/v3. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/containers/podman/v3 — see the affected versions and patch details below.

Podman publishes a malicious image to public registries

Also known asGHSA-66vw-v2x9-hw75GO-2022-0558
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Oct 22, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.2%probability of exploitation in next 30 days
Lower Risk-0.03%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%14.2%28.4%42.6%33.7%4.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/containers/podman/v3🐹github.com/containers/psgo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Podman is a tool for managing OCI containers and pods. A privilege escalation flaw was found in Podman. This flaw allows an attacker to publish a malicious image to a public registry. Once this image is downloaded by a potential victim, the vulnerability is triggered after a user runs the 'podman top' command. This action gives the attacker access to the host filesystem, leading to information disclosure or denial of service.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/containers/podman/v3all versions3.4go get github.com/containers/podman/v3@v3.4
🐹Gogithub.com/containers/psgoall versions1.7.2go get github.com/containers/psgo@v1.7.2

Affected Products

16 products · 20 configurations
OS
fedorafedoraproject
2 versions
3435
Application
podmanpodman_project
< 4.0.0
range
Application
psgopsgo_project
< 1.7.2
range
Application
developer toolsredhat
1 version
1.0
OS
enterprise linuxredhat
2 versions
7.08.0
OS
enterprise linux eusredhat
1 version
8.6
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/containers/podman/v3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/containers/podman/v3 to 3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1227 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat Enterprise Linux 7 Extraspodman-0:1.6.4-32.el7_9RHSA-2022:2190
Red Hat Enterprise Linux 8container-tools:rhel8-8060020220401155929.2e213529RHSA-2022:1762
Red Hat Enterprise Linux 8container-tools:3.0-8060020220419093427.3b538bd8RHSA-2022:2143
Red Hat Enterprise Linux 8.2 Extended Update Supportcontainer-tools:2.0-8020020220420173758.28c38760RHSA-2022:4651
Red Hat Enterprise Linux 8.4 Extended Update Supportcontainer-tools:3.0-8040020220419093313.c0c392d5RHSA-2022:4816
Red Hat Enterprise Linux 8.4 Extended Update Supportcontainer-tools:rhel8-8040020220623181602.c0c392d5RHSA-2022:5622
Red Hat OpenShift Container Platform 4.6podman-0:1.9.3-5.rhaos4.6.el8RHSA-2022:2263

Frequently Asked Questions

Podman is a tool for managing OCI containers and pods. A privilege escalation flaw was found in Podman. This flaw allows an attacker to publish a malicious image to a public registry. Once this image is downloaded by a potential victim, the vulnerability is triggered after a user runs the 'podman top' command. This action gives the attacker access to the host filesystem, leading to information disclosure or denial of service.
O3 Security · Impact-Aware SCA

Is CVE-2022-1227 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2022-1227: podman PrivEsc — Fixed in 3.4