NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2022-1091 — safe-svg

MEDIUMFix: 10up/safe-svg#28

CVE-2022-1091 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in darylldoyle/safe-svg. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for darylldoyle/safe-svg — see the affected versions and patch details below.

Safe SVG < 1.9.10 - SVG Sanitisation Bypass

Also known asGHSA-5h7w-hmxc-99g5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.00%0.57%1.13%1.70%0.5%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘darylldoyle/safe-svg

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The sanitisation step of the Safe SVG WordPress plugin before 1.9.10 can be bypassed by spoofing the content-type in the POST request to upload a file. Exploiting this vulnerability, an attacker will be able to perform the kinds of attacks that this plugin should prevent (mainly XSS, but depending on further use of uploaded SVG files potentially other XML attacks).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistdarylldoyle/safe-svgall versions1.9.10composer require darylldoyle/safe-svg:^1.9.10

Affected Products

1 product · 1 configurations
Application
safe svg10up
< 1.9.10
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for darylldoyle/safe-svg, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update darylldoyle/safe-svg to 1.9.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-1091 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The sanitisation step of the Safe SVG WordPress plugin before 1.9.10 can be bypassed by spoofing the content-type in the POST request to upload a file. Exploiting this vulnerability, an attacker will be able to perform the kinds of attacks that this plugin should prevent (mainly XSS, but depending on further use of uploaded SVG files potentially other XML attacks).
O3 Security · Impact-Aware SCA

Is CVE-2022-1091 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2022-1091: safe-svg XSS — Fixed in 1.9.10