NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2022-0759 — kubeclient

HIGHFix: ManageIQ/kubeclient#556

CVE-2022-0759 is a high-severity (CVSS 8.1) CWE-295 vulnerability in kubeclient. A fix is available for kubeclient — see the affected versions and patch details below.

Improper Certificate Validation in kubeclient

Also known asGHSA-69p3-xp37-f692
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs61th percentile — riskier than 61% of all scored CVEsHighest risk
0.00%0.48%0.96%1.44%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎kubeclient

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

A flaw was found in all versions of kubeclient up to (but not including) v4.9.3, the Ruby client for Kubernetes REST API, in the way it parsed kubeconfig files. When the kubeconfig file does not configure custom CA to verify certs, kubeclient ends up accepting any certificate (it wrongly returns VERIFY_NONE). Ruby applications that leverage kubeclient to parse kubeconfig files are susceptible to Man-in-the-middle attacks (MITM).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemskubeclientall versions4.9.3bundle update kubeclient --conservative

Affected Products

1 product · 1 configurations
Application
kubeclientredhat
< 4.9.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for kubeclient, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update kubeclient to 4.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0759 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Logging subsystem for Red Hat OpenShift 5.4openshift-logging/fluentd-rhel8:v1.14.5-3RHSA-2022:1461
OpenShift Logging 5.2openshift-logging/fluentd-rhel8:v1.7.4-176RHSA-2022:2218
OpenShift Logging 5.3openshift-logging/fluentd-rhel8:v1.7.4-178RHSA-2022:2217
Red Hat Satellite 6.14 for RHEL 8tfm-rubygem-kubeclient-0:4.10.1-1.el8satRHSA-2023:6818
RHOL-5.5-RHEL-8openshift-logging/fluentd-rhel8:v1.14.6-29RHSA-2022:6051

Frequently Asked Questions

A flaw was found in all versions of kubeclient up to (but not including) v4.9.3, the Ruby client for Kubernetes REST API, in the way it parsed kubeconfig files. When the kubeconfig file does not configure custom CA to verify certs, kubeclient ends up accepting any certificate (it wrongly returns VERIFY_NONE). Ruby applications that leverage kubeclient to parse kubeconfig files are susceptible to Man-in-the-middle attacks (MITM).
O3 Security · Impact-Aware SCA

Is CVE-2022-0759 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2022-0759: kubeclient — Fixed in 4.9.3