NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-0624 — parse-path

MEDIUMFix: ionicabizau/parse-path@f9ad885

CVE-2022-0624 is a medium-severity (CVSS 6.5) CWE-639 vulnerability in parse-path. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for parse-path — see the affected versions and patch details below.

Authorization Bypass Through User-Controlled Key in ionicabizau/parse-path

Also known asGHSA-3j8f-xvm3-ffx4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.42%0.1%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

371other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
parse-pathnpm
6.9Mdownloads / week

Description

Authorization Bypass Through User-Controlled Key in GitHub repository ionicabizau/parse-path prior to 5.0.0.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-pathall versions5.0.0npm install parse-path@5.0.0

Affected Products

1 product · 1 configurations
Application
parse-pathparse-path_project
< 5.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-path, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-path to 5.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0624 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Authorization Bypass Through User-Controlled Key in GitHub repository ionicabizau/parse-path prior to 5.0.0.
O3 Security · Impact-Aware SCA

Is CVE-2022-0624 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-0624: parse-path — Fixed in 5.0.0