NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2022-0341 — vditor

MEDIUMFix: vanessa219/vditor@219f8a9

CVE-2022-0341 is a medium-severity (CVSS 6.6) Cross-site Scripting (XSS) vulnerability in vditor. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for vditor — see the affected versions and patch details below.

Cross-site Scripting (XSS) - Stored in vanessa219/vditor

Also known asGHSA-pq37-4c4g-v38c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.65%0.97%0.1%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

85other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
vditornpm
56Kdownloads / week

Description

Cross-site Scripting (XSS) - Stored in GitHub repository vanessa219/vditor prior to 3.8.12.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmvditorall versions3.8.11npm install vditor@3.8.11

Affected Products

1 product · 1 configurations
Application
vditorb3log
< 3.8.12
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vditor, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update vditor to 3.8.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-0341 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository vanessa219/vditor prior to 3.8.12.
O3 Security · Impact-Aware SCA

Is CVE-2022-0341 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2022-0341: vditor XSS — Fixed in 3.8.11