Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
🛡️
CISA KEV · ACTIVELY EXPLOITED
HIGH severity

CVE-2022-0185 — linux

HIGH

CVE-2022-0185 is a high-severity (CVSS 8.4) CWE-190 vulnerability. It is in CISA's Known Exploited Vulnerabilities catalog (added 2024-08-21) — treat it as actively exploited and patch now. A fix is available — see the affected versions and patch details below.

Also known asA-213172369PUB-A-213172369
Published
Updated
Affected
9 products
Patched
See advisory
Exploits
15 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, CISA KEV, FIRST.org (EPSS)

Exploitation Status

Actively exploited in the wild

  • Confirmed by CISA's Known Exploited Vulnerabilities catalog on 2024-08-21. Federal agencies were required to remediate by 2024-09-11.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA (KEV catalog and SSVC triage) for CVE-2022-0185.

EPSS Exploitation Probability

via FIRST.org ↗
25.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%10.7%21.4%32.2%1.8%25.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

CVE-2022-0185 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.

Where this sits among everything scored

Of 395,249 CVEs with a current EPSS score, this one falls in the 10–50% band (highlighted). Counts from FIRST.org, log-scaled.

Description

A heap-based buffer overflow flaw was found in the way the legacy_parse_param function in the Filesystem Context functionality of the Linux kernel verified the supplied parameters length. An unprivileged (in case of unprivileged user namespaces enabled, otherwise needs namespaced CAP_SYS_ADMIN privilege) local user able to open a filesystem that does not support the Filesystem Context API (and thus fallbacks to legacy handling) could use this flaw to escalate their privileges on the system.

Affected Products

9 products · 12 configurations
OS
linux kernellinux
≥ 5.16 && < 5.16.2
range
OS
h300e firmwarenetapp
all
OS
h300s firmwarenetapp
all
OS
h410c firmwarenetapp
all
OS
h410s firmwarenetapp
all
OS
h500e firmwarenetapp
all
Exploits & PoCs
15

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Vulnerability
  1. Detect

    Identify every host running the affected component and compare the installed build against the fixed version below — for source-built or distro-packaged software the version string, not a lockfile, is the source of truth (`dpkg -l`, `rpm -q`, or the binary's own `--version`).

  2. Fix

    Upgrade the affected component to the fixed release for CVE-2022-0185, or apply your distribution's backported patch — distro builds are often patched at an older version number, so check your vendor's advisory rather than the upstream version alone.

  3. Workarounds

    Stop feeding it untrusted input: reject or quarantine files and payloads from unverified sources until you can upgrade, restrict accepted formats to the ones you actually need, and run the parsing or decoding step in a least-privileged sandbox or short-lived worker so a crash or corrupted read cannot reach the rest of the process.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This issue affects the Linux kernel packages as shipped with Red Hat Enterprise Linux 8.4 GA onwards. Previous Red Hat Enterprise Linux versions are not affected.

Workaround published by Red Hat
On non-containerized deployments of Red Hat Enterprise Linux 8, you can disable user namespaces by setting user.max_user_namespaces to 0: # echo "user.max_user_namespaces=0" > /etc/sysctl.d/userns.conf # sysctl -p /etc/sysctl.d/userns.conf On containerized deployments, such as Red Hat OpenShift Container Platform, do not use this mitigation as the functionality is needed to be enabled.
Source: Red Hat security advisory for CVE-2022-0185 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 8kernel-rt-0:4.18.0-348.12.2.rt7.143.el8_5RHSA-2022:0176
Red Hat Enterprise Linux 8kernel-0:4.18.0-348.12.2.el8_5RHSA-2022:0188
Red Hat Enterprise Linux 8kpatch-patchRHSA-2022:0232
Red Hat Enterprise Linux 8.4 Extended Update Supportkernel-rt-0:4.18.0-305.34.2.rt7.107.el8_4RHSA-2022:0187
Red Hat Enterprise Linux 8.4 Extended Update Supportkernel-0:4.18.0-305.34.2.el8_4RHSA-2022:0186
Red Hat Enterprise Linux 8.4 Extended Update Supportkpatch-patchRHSA-2022:0231
Red Hat Virtualization 4 for Red Hat Enterprise Linux 8redhat-virtualization-host-0:4.4.10-202202081536_8.5RHSA-2022:0540

Frequently Asked Questions

A heap-based buffer overflow flaw was found in the way the legacy_parse_param function in the Filesystem Context functionality of the Linux kernel verified the supplied parameters length. An unprivileged (in case of unprivileged user namespaces enabled, otherwise needs namespaced CAP_SYS_ADMIN privilege) local user able to open a filesystem that does not support the Filesystem Context API (and thus fallbacks to legacy handling) could use this flaw to escalate their privileges on the system.
O3 Security · Impact-Aware SCA

Is CVE-2022-0185 in your dependencies?

Find it across , including transitive dependencies.

CVE-2022-0185: linux Memory Corruption (High 8.4, KEV)