CVE-2021-43138 is a high-severity (CVSS 7.8) CWE-1321 vulnerability in async. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for async — see the affected versions and patch details below.
Prototype Pollution in async
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
asyncnpmDescription
A vulnerability exists in Async through 3.2.1 for 3.x and through 2.6.3 for 2.x (fixed in 3.2.2 and 2.6.4), which could let a malicious user obtain privileges via the mapValues() method.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | async | ≥ 3.0.0&&< 3.2.2 | 3.2.2npm install async@3.2.2 |
| 📦npm | async | ≥ 2.0.0&&< 2.6.4 | 2.6.4npm install async@2.6.4 |
Affected Products
asyncasync_projectfedorafedoraprojectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for async, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update async to 3.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-43138 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Migration Toolkit for Containers 1.7 | rhmtc/openshift-migration-ui-rhel8:v1.7.7-3 | RHSA-2023:0693 |
| Red Hat OpenShift Service Mesh 2.2 for RHEL 8 | openshift-service-mesh/prometheus-rhel8:2.2.7-7 | RHSA-2023:3645 |
Frequently Asked Questions
Is CVE-2021-43138 in your dependencies?
Find it across npm, including transitive dependencies.