NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-41952 — zenario

MEDIUMFix: TribalSystems/Zenario@4566d8a

CVE-2021-41952 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in tribalsystems/zenario. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for tribalsystems/zenario — see the affected versions and patch details below.

Cross-site Scripting in Zenario CMS

Also known asGHSA-x8wj-cqmp-3wmm
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.68%1.01%0.2%0.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘tribalsystems/zenario

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Zenario CMS 9.0.54156 is vulnerable to Cross Site Scripting (XSS) via upload file to *.SVG. An attacker can send malicious files to victims and steals victim's cookie leads to account takeover. The person viewing the image of a contact can be victim of XSS.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttribalsystems/zenarioall versions9.0.55143composer require tribalsystems/zenario:^9.0.55143

Affected Products

1 product · 1 configurations
Application
zenariotribalsystems
1 version
9.0.54156
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tribalsystems/zenario, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tribalsystems/zenario to 9.0.55143 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-41952 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Zenario CMS 9.0.54156 is vulnerable to Cross Site Scripting (XSS) via upload file to *.SVG. An attacker can send malicious files to victims and steals victim's cookie leads to account takeover. The person viewing the image of a contact can be victim of XSS.
O3 Security · Impact-Aware SCA

Is CVE-2021-41952 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-41952: zenario XSS — Fixed in 9.0.55143