NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2021-41143 — magento-lts

HIGHFix: OpenMage/magento-lts@45330ff

CVE-2021-41143 is a high-severity (CVSS 7.2) CWE-77 vulnerability in openmage/magento-lts. A fix is available for openmage/magento-lts — see the affected versions and patch details below.

Fix for arbitrary file deletion in customer media allows for remote code execution

Also known asGHSA-5vpv-xmcj-9q85
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2021-41143.

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs70th percentile — riskier than 70% of all scored CVEsHighest risk
0.72%1.08%1.44%1.79%1.2%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘openmage/magento-lts🐘openmage/magento-lts

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Magento admin users with access to the customer media could execute code on the server. Versions 19.4.22 and 20.0.19 contain a patch for this issue.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistopenmage/magento-ltsall versions19.4.22composer require openmage/magento-lts:^19.4.22
🐘Packagistopenmage/magento-lts≥ 20.0.0&&< 20.0.1920.0.19composer require openmage/magento-lts:^20.0.19

Affected Products

1 product · 2 configurations
Application
magentoopenmage
≥ 20.0.0 && < 20.0.19
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openmage/magento-lts, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openmage/magento-lts to 19.4.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-41143 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Magento admin users with access to the customer media could execute code on the server. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
O3 Security · Impact-Aware SCA

Is CVE-2021-41143 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-41143: magento-lts — Fixed in 19.4.22