NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2021-40143 — nexus-repository

HIGH

CVE-2021-40143 is a high-severity (CVSS 8.2) CWE-74 vulnerability in org.sonatype.nexus:nexus-repository. A fix is available for org.sonatype.nexus:nexus-repository — see the affected versions and patch details below.

HTTP header injection in Sonatype Nexus Repository

Also known asGHSA-f34x-8pf6-qc9c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
1.71%2.08%2.45%2.82%2.2%2.3%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.sonatype.nexus:nexus-repository

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Sonatype Nexus Repository 3.x through 3.33.1-01 is vulnerable to an HTTP header injection. By sending a crafted HTTP request, a remote attacker may disclose sensitive information or request external resources from a vulnerable instance.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.sonatype.nexus:nexus-repository≥ 3.0.0&&< 3.34.0-013.34.0-01org.sonatype.nexus:nexus-repository:3.34.0-01

Affected Products

1 product · 1 configurations
Application
nexus repository managersonatype
≥ 3.0.0 && < 3.34.1-01
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.sonatype.nexus:nexus-repository, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.sonatype.nexus:nexus-repository to 3.34.0-01 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-40143 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Sonatype Nexus Repository 3.x through 3.33.1-01 is vulnerable to an HTTP header injection. By sending a crafted HTTP request, a remote attacker may disclose sensitive information or request external resources from a vulnerable instance.
O3 Security · Impact-Aware SCA

Is CVE-2021-40143 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-40143: nexus Info Disclosure — Fixed in 3.34.0-01