CVE-2019-16530 — nexus-repository
HIGHCVE-2019-16530 is a high-severity (CVSS 7.2) Unrestricted File Upload vulnerability in org.sonatype.nexus:nexus-repository. A fix is available for org.sonatype.nexus:nexus-repository — see the affected versions and patch details below.
Unrestricted Upload of File with Dangerous Type in Sonatype Nexus Repository Manager
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.sonatype.nexus:nexus-repository☕org.sonatype.nexus:nexus-repositoryReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Sonatype Nexus Repository Manager 2.x before 2.14.15 and 3.x before 3.19, and IQ Server before 72, has remote code execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.sonatype.nexus:nexus-repository | ≥ 2.0.0&&< 2.14.15 | 2.14.15org.sonatype.nexus:nexus-repository:2.14.15 |
| ☕Maven | org.sonatype.nexus:nexus-repository | ≥ 3.0.0&&< 3.19.0 | 3.19.0org.sonatype.nexus:nexus-repository:3.19.0 |
Affected Products
nexus iq serversonatypenexus repository managersonatypeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.sonatype.nexus:nexus-repository, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.sonatype.nexus:nexus-repository to 2.14.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-16530 is resolved across your whole dependency graph.
Workarounds
Treat uploaded files as untrusted until proven otherwise: validate the actual content type rather than the supplied extension, store uploads outside the web root on a volume mounted without execute permission, and rename them to server-generated identifiers so an attacker cannot choose the path a request will later resolve.
Frequently Asked Questions
Is CVE-2019-16530 in your dependencies?
Find it across Maven, including transitive dependencies.