CVE-2021-3690 is a high-severity (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in io.undertow:undertow-core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for io.undertow:undertow-core — see the affected versions and patch details below.
Undertow vulnerable to memory exhaustion due to buffer leak
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.undertow:undertow-core☕io.undertow:undertow-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in Undertow. A buffer leak on the incoming WebSocket PONG message may lead to memory exhaustion. This flaw allows an attacker to cause a denial of service. The highest threat from this vulnerability is availability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.undertow:undertow-core | all versions | 2.0.40io.undertow:undertow-core:2.0.40 |
| ☕Maven | io.undertow:undertow-core | ≥ 2.2.0&&< 2.2.10 | 2.2.10io.undertow:undertow-core:2.2.10 |
Affected Products
fuseredhatintegration camel kredhatintegration camel quarkusredhatjboss enterprise application platformredhatopenshift application runtimesredhatsingle sign-onredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.undertow:undertow-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.undertow:undertow-core to 2.0.40 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3690 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Although Red Hat OpenStack Platform packages the vulnerable code in Opendaylight, it does not use or support the undertow-encapsulating features. The security impact for RHOSP is therefore rated as Low and no update will be provided at this time.
| Product | Fixed in | Advisory |
|---|---|---|
| EAP 7.3.9 release | undertow | RHSA-2021:3471 |
| EAP 7.3 async | see advisory | RHSA-2021:3216 |
| Red Hat EAP-XP 2.0.0 via EAP 7.3.x base | undertow | RHSA-2021:3516 |
| Red Hat Fuse 7.10 | undertow | RHSA-2021:5134 |
| Red Hat Integration Camel Quarkus 2 | see advisory | RHSA-2021:4767 |
| Red Hat JBoss Enterprise Application Platform | io.undertow/undertow-core:2.2.5.Final-redhat-00001 | RHSA-2021:3218 |
| Red Hat JBoss Enterprise Application Platform | io.undertow/undertow-core:2.2.9.SP1-redhat-00001 | RHSA-2021:3660 |
| Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7 | eap7-activemq-artemis-0:1.5.5.016-1.redhat_00001.1.ep7.el7 | RHSA-2025:4226 |
Frequently Asked Questions
Is CVE-2021-3690 in your dependencies?
Find it across Maven, including transitive dependencies.