NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2021-3689 — yii2-dev

HIGHFix: yiisoft/yii2@13f27e4

CVE-2021-3689 is a high-severity (CVSS 7.5) CWE-1241 vulnerability in yiisoft/yii2-dev. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for yiisoft/yii2-dev — see the affected versions and patch details below.

Use of Insufficiently Random Values in yiisoft/yii2-dev

Also known asGHSA-hq3v-rg6f-6hx4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.80%1.60%2.40%0.4%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘yiisoft/yii2-dev

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

yii2 is vulnerable to Use of Predictable Algorithm in Random Number Generator

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistyiisoft/yii2-devall versions2.0.43composer require yiisoft/yii2-dev:^2.0.43

Affected Products

1 product · 1 configurations
Application
yiiyiiframework
≥ 2.0.0 && < 2.0.43
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yiisoft/yii2-dev, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update yiisoft/yii2-dev to 2.0.43 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3689 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

yii2 is vulnerable to Use of Predictable Algorithm in Random Number Generator
O3 Security · Impact-Aware SCA

Is CVE-2021-3689 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-3689: yii2-dev — Fixed in 2.0.43