CVE-2018-6009 is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in yiisoft/yii2. A fix is available for yiisoft/yii2 — see the affected versions and patch details below.
Yii Framework Cross-Site Request Forgery (CSRF)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
yiisoft/yii2🐘yiisoft/yii2-devReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Yii Framework 2.x before 2.0.14, the switchIdentity function in web/User.php did not regenerate the CSRF token upon a change of identity.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | yiisoft/yii2 | ≥ 2.0&&< 2.0.14 | 2.0.14composer require yiisoft/yii2:^2.0.14 |
| 🐘Packagist | yiisoft/yii2-dev | ≥ 2.0&&< 2.0.14 | 2.0.14composer require yiisoft/yii2-dev:^2.0.14 |
Affected Products
yiiframeworkyiiframeworkDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yiisoft/yii2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update yiisoft/yii2 to 2.0.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-6009 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2018-6009 in your dependencies?
Find it across Packagist, including transitive dependencies.