CVE-2021-36090 — commons-compress
HIGHCVE-2021-36090 is a high-severity (CVSS 7.5) CWE-130 vulnerability in org.apache.commons:commons-compress. EPSS puts its 30-day exploitation probability at 12.9% (96th percentile). A fix is available for org.apache.commons:commons-compress — see the affected versions and patch details below.
Improper Handling of Length Parameter Inconsistency in Compress
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2021-36090.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.commons:commons-compressReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
When reading a specially crafted ZIP archive, Compress can be made to allocate large amounts of memory that finally leads to an out of memory error even for very small inputs. This could be used to mount a denial of service attack against services that use Compress' zip package.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.commons:commons-compress | all versions | 1.21org.apache.commons:commons-compress:1.21 |
Affected Products
commons compressapacheactive iq unified managernetapponcommand insightnetappbanking apisoraclebanking digital experienceoraclebanking enterprise default managementoracleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.commons:commons-compress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.commons:commons-compress to 1.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-36090 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.11 | apache-commons-compress | RHSA-2022:5532 |
| Red Hat Virtualization Engine 4.4 | apache-commons-compress-0:1.21-1.2.el8ev | RHSA-2022:5555 |
Frequently Asked Questions
Is CVE-2021-36090 in your dependencies?
Find it across Maven, including transitive dependencies.