CVE-2019-12402 — commons-compress
HIGHCVE-2019-12402 is a high-severity (CVSS 7.5) CWE-835 vulnerability in org.apache.commons:commons-compress. EPSS puts its 30-day exploitation probability at 16.2% (97th percentile). A fix is available for org.apache.commons:commons-compress — see the affected versions and patch details below.
Denial of Service in Apache Commons Compress
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.commons:commons-compress☕io.github.1tchy.java9modular.org.apache.commons:commons-compressReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
The file name encoding algorithm used internally in Apache Commons Compress 1.15 to 1.18 can get into an infinite loop when faced with specially crafted inputs. This can lead to a denial of service attack if an attacker can choose the file names inside of an archive created by Compress.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.commons:commons-compress | ≥ 1.15&&< 1.19 | 1.19org.apache.commons:commons-compress:1.19 |
| ☕Maven | io.github.1tchy.java9modular.org.apache.commons:commons-compress | all versions | No fix |
Affected Products
commons compressapachefedorafedoraprojectbanking paymentsoraclebanking platformoraclecommunications element manageroraclecommunications ip service activatororacleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.commons:commons-compress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.commons:commons-compress to 1.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-12402 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This issue does not affect the versions of apache-commons-compress as shipped with Red Hat Enterprise Linux 7, and the versions of rh-java-common-apache-commons-compress and rh-maven35-apache-commons-compress as shipped with Red Hat Software Collections 3, as they used a fallback zip encoding implementation…
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Fuse 7.9 | apache-commons-compress | RHSA-2021:3140 |
Frequently Asked Questions
Is CVE-2019-12402 in your dependencies?
Find it across Maven, including transitive dependencies.