CVE-2021-3538 is a critical-severity (CVSS 9.8) CWE-338 vulnerability in github.com/satori/go.uuid. A fix is available for github.com/satori/go.uuid — see the affected versions and patch details below.
go.uuid has Predictable UUID Identifiers
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/satori/go.uuidReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
CVE Description for go.uuid
A flaw was found in github.com/satori/go.uuid in versions from commit 0ef6afb2f6cdd6cdaeee3885a95099c63f18fc8c to d91630c8510268e75203009fe7daf2b8e1d60c45. Due to insecure randomness in the g.rand.Read function the generated UUIDs are predictable for an attacker.
Update on 19 September 2024 -- This vulnerability never existed in sif
The official NIST CVE-2021-3538 record says:
A flaw was found in github.com/satori/go.uuid in versions from commit 0ef6afb2f6cdd6cdaeee3885a95099c63f18fc8c to d91630c8510268e75203009fe7daf2b8e1d60c45.
That commit and that fix were never in a tagged release of satori/go.uuid, and prior to this announcement sif had used the last tag, 1.2.0. The NIST record says version 1.2.0 was vulnerable, but that's not true. So sif was never vulnerable to this. Also, beginning with version 2.0.0, sif does not use satori/go.uuid anymore.
This update was made in response to issue #243 which has more details.
The original, incorrect sif vulnerability description is below.
Impact
The siftool new command produces predictable UUID identifiers due to insecure randomness in the version of the github.com/satori/go.uuid module used as a dependency.
Patches
A patch is available in version >= v1.2.2 of the module. Users are encouraged to upgrade.
Fixed by https://github.com/hpcng/sif/pull/90
Workarounds
Users passing CreateInfo struct should ensure the ID field is generated using a version of github.com/satori/go.uuid that is not vulnerable to this issue. Unfortunately, the latest tagged release is vulnerable to this issue. One way to obtain a non-vulnerable version is:
go get -u github.com/satori/[email protected]
References
https://github.com/satori/go.uuid/issues/73
For more information
If you have any questions or comments about this advisory:
Open an issue in https://github.com/hpcng/sif/issues
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/satori/go.uuid | ≥ 1.2.1-0.20180103161547-0ef6afb2f6cd&&< 1.2.1-0.20180404165556-75cca531ea76 | 1.2.1-0.20180404165556-75cca531ea76go get github.com/satori/go.uuid@v1.2.1-0.20180404165556-75cca531ea76 |
Affected Products
uuidsatoriDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/satori/go.uuid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/satori/go.uuid to 1.2.1-0.20180404165556-75cca531ea76 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3538 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-3538 in your dependencies?
Find it across Go, including transitive dependencies.