NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2021-3291 — zencart

HIGHFix: zencart/zencart@7447627

CVE-2021-3291 is a high-severity (CVSS 7.2) OS Command Injection vulnerability in zencart/zencart. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for zencart/zencart — see the affected versions and patch details below.

Zen Cart vulnerable to authenticated remote code execution

Also known asGHSA-38f9-4vhq-9cr8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
17.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
12.0%20.5%28.9%37.4%32.6%17.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘zencart/zencart

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Zen Cart 1.5.7b allows admins to execute arbitrary OS commands by inspecting an HTML radio input element (within the modules edit page) and inserting a command.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzencart/zencartall versions1.5.7ccomposer require zencart/zencart:^1.5.7c

Affected Products

1 product · 1 configurations
Application
zen cartzen-cart
1 version
1.5.7b
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-49608webappsphp✓ Verified

Zen Cart 1.5.7b - Remote Code Execution (Authenticated)

by Mücahit Saratar · Mar 2, 2021

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zencart/zencart, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zencart/zencart to 1.5.7c or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3291 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Zen Cart 1.5.7b allows admins to execute arbitrary OS commands by inspecting an HTML radio input element (within the modules edit page) and inserting a command.
O3 Security · Impact-Aware SCA

Is CVE-2021-3291 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-3291: zencart — Fixed in 1.5.7c