NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-6578 — zencart

MEDIUMFix: zencart/zencart@aa11e1e

CVE-2020-6578 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in zencart/zencart. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for zencart/zencart — see the affected versions and patch details below.

Reflected XSS in Zen Cart before 1.5.7a

Also known asGHSA-wxxx-2x6v-979f
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs58th percentile — riskier than 58% of all scored CVEsHighest risk
0.00%0.45%0.90%1.34%0.2%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘zencart/zencart

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Zen Cart 1.5.6d allows reflected XSS via the main_page parameter to includes/templates/template_default/common/tpl_main_page.php or includes/templates/responsive_classic/common/tpl_main_page.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistzencart/zencartall versions1.5.7acomposer require zencart/zencart:^1.5.7a

Affected Products

1 product · 1 configurations
Application
zen cartzen-cart
1 version
1.5.6d
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for zencart/zencart, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update zencart/zencart to 1.5.7a or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-6578 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Zen Cart 1.5.6d allows reflected XSS via the main_page parameter to includes/templates/template_default/common/tpl_main_page.php or includes/templates/responsive_classic/common/tpl_main_page.php.
O3 Security · Impact-Aware SCA

Is CVE-2020-6578 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-6578: zencart XSS — Fixed in 1.5.7a