CVE-2021-30180 — dubbo
CRITICALCVE-2021-30180 is a critical-severity (CVSS 9.8) CWE-444 vulnerability in org.apache.dubbo:dubbo. EPSS puts its 30-day exploitation probability at 60.3% (99th percentile). A fix is available for org.apache.dubbo:dubbo — see the affected versions and patch details below.
Code injection in Apache Dubbo
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.dubbo:dubboReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache Dubbo prior to 2.7.9 support Tag routing which will enable a customer to route the request to the right server. These rules are used by the customers when making a request in order to find the right endpoint. When parsing these YAML rules, Dubbo customers may enable calling arbitrary constructors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.dubbo:dubbo | ≥ 2.7.0&&< 2.7.10 | 2.7.10org.apache.dubbo:dubbo:2.7.10 |
Affected Products
dubboapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.dubbo:dubbo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.dubbo:dubbo to 2.7.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-30180 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-30180 in your dependencies?
Find it across Maven, including transitive dependencies.