CVE-2021-30080 is a critical-severity (CVSS 9.8) vulnerability in github.com/beego/beego/v2. A fix is available for github.com/beego/beego/v2 — see the affected versions and patch details below.
Access control bypass in Beego
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/beego/beego/v2🐹github.com/beego/beegoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the route lookup process in beego before 1.12.11 that allows attackers to bypass access control.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/beego/beego/v2 | ≥ 2.0.0&&< 2.0.3 | 2.0.3go get github.com/beego/beego/v2@v2.0.3 |
| 🐹Go | github.com/beego/beego | all versions | No fix |
Affected Products
beegobeegoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/beego/beego/v2, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/beego/beego/v2 to 2.0.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-30080 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2021-30080 in your dependencies?
Find it across Go, including transitive dependencies.