NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-28380 — aimeos-typo3

MEDIUM

CVE-2021-28380 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in aimeos/aimeos-typo3. A fix is available for aimeos/aimeos-typo3 — see the affected versions and patch details below.

Aimeos Typo3 extension contains Cross-site Scripting vulnerability

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk+0.05%
Lower risk than most CVEs46th percentile — riskier than 46% of all scored CVEsHighest risk
0.00%0.35%0.70%1.05%0.3%0.6%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘aimeos/aimeos-typo3🐘aimeos/aimeos-typo3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The aimeos (aka Aimeos shop and e-commerce framework) extension before 19.10.12 and 20.x before 20.10.5 for TYPO3 allows Cross-site Scripting (XSS) via a backend user account.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistaimeos/aimeos-typo3all versions19.10.12composer require aimeos/aimeos-typo3:^19.10.12
🐘Packagistaimeos/aimeos-typo3≥ 20.0.0&&< 20.10.520.10.5composer require aimeos/aimeos-typo3:^20.10.5

Affected Products

1 product · 2 configurations
Application
aimeosaimeos_project
≥ 20.0.0 && < 20.10.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for aimeos/aimeos-typo3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update aimeos/aimeos-typo3 to 19.10.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-28380 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The aimeos (aka Aimeos shop and e-commerce framework) extension before 19.10.12 and 20.x before 20.10.5 for TYPO3 allows Cross-site Scripting (XSS) via a backend user account.
O3 Security · Impact-Aware SCA

Is CVE-2021-28380 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-28380: aimeos-typo3 XSS — Fixed in 19.10.12