NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2021-26601 — impresscms

HIGHFix: ImpressCMS/impresscms#915

CVE-2021-26601 is a high-severity (CVSS 8.1) Path Traversal vulnerability in impresscms/impresscms. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for impresscms/impresscms — see the affected versions and patch details below.

Path Traversal in ImpressCMS

Also known asGHSA-4q96-9f63-p7jj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
3 known
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.57%5.22%9.88%14.5%11.9%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘impresscms/impresscms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

ImpressCMS before 1.4.3 allows libraries/image-editor/image-edit.php image_temp Directory Traversal.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistimpresscms/impresscmsall versions1.4.3composer require impresscms/impresscms:^1.4.3

Affected Products

1 product · 1 configurations
Application
impresscmsimpresscms
< 1.4.3
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for impresscms/impresscms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update impresscms/impresscms to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-26601 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

ImpressCMS before 1.4.3 allows libraries/image-editor/image-edit.php image_temp Directory Traversal.
O3 Security · Impact-Aware SCA

Is CVE-2021-26601 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-26601: impresscms — Fixed in 1.4.3