NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2021-26599 — impresscms

CRITICAL

CVE-2021-26599 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in impresscms/impresscms. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for impresscms/impresscms — see the affected versions and patch details below.

SQL Injection in ImpressCMS

Also known asGHSA-jc4v-vvg6-xg78
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
4 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
21.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.00%8.69%17.4%26.1%3.9%21.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘impresscms/impresscms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

ImpressCMS before 1.4.3 allows include/findusers.php groups SQL Injection.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistimpresscms/impresscmsall versions1.4.3composer require impresscms/impresscms:^1.4.3

Affected Products

1 product · 1 configurations
Application
impresscmsimpresscms
< 1.4.4
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-50839webappsphp

ImpressCMS 1.4.2 - Remote Code Execution (RCE)

by Egidio Romano · Mar 30, 2022

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for impresscms/impresscms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update impresscms/impresscms to 1.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-26599 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

How to detect CVE-2021-26599

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2021-26599 -u https://target
Template
ImpressCMS < 1.4.3 - SQL Injection
Severity
high
Impact
Unauthenticated attackers can execute arbitrary SQL queries via SQL injection, potentially extracting sensitive database contents or modifying data.
Remediation
Update ImpressCMS to version 1.4.3 or later.

Template by ProjectDiscovery nuclei-templates (ritikchaddha), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

ImpressCMS before 1.4.3 allows include/findusers.php groups SQL Injection.
O3 Security · Impact-Aware SCA

Is CVE-2021-26599 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-26599: impresscms — Fixed in 1.4.3