NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

CVE-2021-26271 — ckeditor4-dev

MEDIUM

CVE-2021-26271 is a medium-severity (CVSS 6.5) CWE-829 vulnerability in ckeditor4-dev. A fix is available for ckeditor4-dev — see the affected versions and patch details below.

CKEditor 4 ReDoS Vulnerability

Also known asGHSA-jv4c-7jqq-m34x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.12%0.91%1.70%2.49%0.6%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

ckeditor4-devnpm
36downloads / week

Description

It was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted text into the Styles input of specific dialogs (in the Advanced Tab for Dialogs plugin).

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmckeditor4-devall versions4.16npm install ckeditor4-dev@4.16

Affected Products

7 products · 11 configurations
Application
ckeditorckeditor
≥ 4.0 && < 4.16
range
Application
agile product lifecycle managementoracle
2 versions
9.3.59.3.6
Application
application expressoracle
< 21.1.0
range
Application
financial services analytical applications infrastructureoracle
≥ 8.0.6 && ≤ 8.0.9
2 versions
8.1.08.1.1
Application
jd edwards enterpriseone toolsoracle
< 9.2.6.0
range
Application
siebel ui frameworkoracle
< 21.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for ckeditor4-dev, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update ckeditor4-dev to 4.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-26271 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

It was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted text into the Styles input of specific dialogs (in the Advanced Tab for Dialogs plugin).
O3 Security · Impact-Aware SCA

Is CVE-2021-26271 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-26271: ckeditor4-dev — Fixed in 4.16