NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2021-25641 — dubbo

CRITICAL

CVE-2021-25641 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.apache.dubbo:dubbo. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.apache.dubbo:dubbo — see the affected versions and patch details below.

Deserializer tampering in Apache Dubbo

Also known asGHSA-v2rg-8cwr-75g8
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
4 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
21.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs98th percentile — riskier than 98% of all scored CVEsHighest risk
0.58%31.0%61.3%91.7%74.6%21.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.dubbo:dubbo☕com.alibaba:dubbo

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Each Apache Dubbo server will set a serialization id to tell the clients which serialization protocol it is working on. But for Dubbo versions before 2.7.8 or 2.6.9, an attacker can choose which serialization id the Provider will use by tampering with the byte preamble flags, aka, not following the server's instruction. This means that if a weak deserializer such as the Kryo and FST are somehow in code scope (e.g. if Kryo is somehow a part of a dependency), a remote unauthenticated attacker can tell the Provider to use the weak deserializer, and then proceed to exploit it.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.dubbo:dubbo≥ 2.5.0&&< 2.7.82.7.8org.apache.dubbo:dubbo:2.7.8
☕Mavencom.alibaba:dubbo≥ 2.5.0&&< 2.6.92.6.9com.alibaba:dubbo:2.6.9

Affected Products

1 product · 2 configurations
Application
dubboapache
≥ 2.7.0 && < 2.7.8
range
Exploits & PoCs
4

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.dubbo:dubbo, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.dubbo:dubbo to 2.7.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-25641 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Each Apache Dubbo server will set a serialization id to tell the clients which serialization protocol it is working on. But for Dubbo versions before 2.7.8 or 2.6.9, an attacker can choose which serialization id the Provider will use by tampering with the byte preamble flags, aka, not following the server's instruction. This means that if a weak deserializer such as the Kryo and FST are somehow in code scope (e.g. if Kryo is somehow a part of a dependency), a remote unauthenticated attacker can tell the Provider to use the weak deserializer, and then proceed to exploit it.
O3 Security · Impact-Aware SCA

Is CVE-2021-25641 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-25641: dubbo — Fixed in 2.7.8