NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2021-23451 — otp-generator

CRITICALFix: Maheshkumar-Kakade/otp-generator@b27de1c

CVE-2021-23451 is a critical-severity (CVSS 9.8) Insufficient Random Values vulnerability in otp-generator. A fix is available for otp-generator — see the affected versions and patch details below.

otp-generator before v3.0.0 insecurely generates random one-time passwords

Also known asGHSA-6x93-h9g3-9phr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.41%0.4%0.9%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

73other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
otp-generatornpm
126Kdownloads / week

Description

The package otp-generator before 3.0.0 are vulnerable to Insecure Randomness due to insecure generation of random one-time passwords, which may allow a brute-force attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmotp-generatorall versions3.0.0npm install otp-generator@3.0.0

Affected Products

1 product · 1 configurations
Application
otp-generatorotp-generator_project
< 3.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for otp-generator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update otp-generator to 3.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-23451 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package otp-generator before 3.0.0 are vulnerable to Insecure Randomness due to insecure generation of random one-time passwords, which may allow a brute-force attack.
O3 Security · Impact-Aware SCA

Is CVE-2021-23451 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-23451: otp-generator — Fixed in 3.0.0