NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-21644 — config-file-provider

MEDIUMFix: jenkinsci/config-file-provider-plugin@9ffc323

CVE-2021-21644 is a medium-severity (CVSS 5.4) Cross-Site Request Forgery (CSRF) vulnerability in org.jenkins-ci.plugins:config-file-provider. A fix is available for org.jenkins-ci.plugins:config-file-provider — see the affected versions and patch details below.

CSRF vulnerability in Jenkins Config File Provider Plugin allows deleting configuration files

Also known asGHSA-998m-f2x3-jjq4
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.04%1.55%0.1%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:config-file-provider

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Config File Provider Plugin 3.7.0 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability.

This vulnerability allows attackers to delete configuration files corresponding to an attacker-specified ID.

This is due to an incomplete fix of SECURITY-938.

Jenkins Config File Provider Plugin 3.7.1 requires POST requests for the affected HTTP endpoint.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:config-file-providerall versions3.7.1org.jenkins-ci.plugins:config-file-provider:3.7.1

Affected Products

1 product · 1 configurations
Application
config file providerjenkins
≤ 3.7.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:config-file-provider, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:config-file-provider to 3.7.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21644 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Migration Toolkit for Containers 1.4rhmtc/openshift-migration-controller-rhel8:v1.4.6-4RHBA-2021:2854
Red Hat OpenShift Container Platform 3.11jenkins-2-plugins-0:3.11.1624366838-1.el7RHSA-2021:2517
Red Hat OpenShift Container Platform 4.5jenkins-2-plugins-0:4.5.1623326336-1.el7RHSA-2021:2431
Red Hat OpenShift Container Platform 4.6jenkins-2-plugins-0:4.6.1623162648-1.el8RHBA-2021:2407
Red Hat OpenShift Container Platform 4.7cri-o-0:1.20.2-12.rhaos4.7.git9f7be76.el7RHSA-2021:2122
Red Hat OpenShift Container Platform 4.8atomic-openshift-service-idler-0:4.8.0-202106281541.p0.git.39cfc66.assembly.stream.el8RHSA-2021:2437

Frequently Asked Questions

Jenkins Config File Provider Plugin 3.7.0 and earlier does not require POST requests for an HTTP endpoint, resulting in a cross-site request forgery (CSRF) vulnerability. This vulnerability allows attackers to delete configuration files corresponding to an attacker-specified ID. This is due to an incomplete fix of [SECURITY-938](https://www.jenkins.io/security/advisory/2018-09-25/#SECURITY-938). Jenkins Config File Provider Plugin 3.7.1 requires POST requests for the affected HTTP endpoint.
O3 Security · Impact-Aware SCA

Is CVE-2021-21644 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-21644: config-file-provider CSRF — Fixed in 3.7.1