NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2017-1000104 — config-file-provider

MEDIUM

CVE-2017-1000104 is a medium-severity (CVSS 6.5) Improper Privilege Management vulnerability in org.jenkins-ci.plugins:config-file-provider. A fix is available for org.jenkins-ci.plugins:config-file-provider — see the affected versions and patch details below.

Improper Privilege Management in Jenkins Config File Provider Plugin

Also known asGHSA-6h72-m3xw-fp3c
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.88%1.32%0.0%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:config-file-provider

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The Config File Provider Plugin is used to centrally manage configuration files that often include secrets, such as passwords. Users with only Overall/Read access to Jenkins were able to access URLs directly that allowed viewing these files. Access to view these files now requires sufficient permissions to configure the provided files, view the configuration of the folder in which the configuration files are defined, or have Job/Configure permissions to a job able to use these files.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:config-file-providerall versions2.16.2org.jenkins-ci.plugins:config-file-provider:2.16.2

Affected Products

1 product · 1 configurations
Application
config file providerjenkins
≤ 2.16.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:config-file-provider, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:config-file-provider to 2.16.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-1000104 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

The Config File Provider Plugin is used to centrally manage configuration files that often include secrets, such as passwords. Users with only Overall/Read access to Jenkins were able to access URLs directly that allowed viewing these files. Access to view these files now requires sufficient permissions to configure the provided files, view the configuration of the folder in which the configuration files are defined, or have Job/Configure permissions to a job able to use these files.
O3 Security · Impact-Aware SCA

Is CVE-2017-1000104 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-1000104: config-file-provider — Fixed in 2.16.2