CVE-2020-8163 — actionview
HIGHCVE-2020-8163 is a high-severity (CVSS 8.8) Code Injection vulnerability in actionview. 6 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for actionview — see the affected versions and patch details below.
Remote code execution via user-provided local names in ActionView
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
actionviewReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
The is a code injection vulnerability in versions of Rails prior to 5.0.1 that would allow an attacker who controlled the locals argument of a render call to perform a RCE.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | actionview | all versions | 4.2.11.3bundle update actionview --conservative |
Affected Products
debian linuxdebianrailsrubyonrailsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Rails 5.0.1 - Remote Code Execution
by Lucas Amorim · Jul 26, 2020
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for actionview, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update actionview to 4.2.11.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-8163 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
How to detect CVE-2020-8163
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2020-8163 -u https://target- Template
- Ruby on Rails <5.0.1 - Remote Code Execution
- Severity
- high
- Impact
- Successful exploitation of this vulnerability can lead to unauthorized remote code execution.
- Remediation
- Upgrade Ruby on Rails to version 5.0.1 or above.
Template by ProjectDiscovery nuclei-templates (tim_koopmans), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2020-8163 in your dependencies?
Find it across RubyGems, including transitive dependencies.