NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-8128 — jsreport

CRITICAL

CVE-2020-8128 is a critical-severity (CVSS 9.8) CWE-829 vulnerability in jsreport. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for jsreport — see the affected versions and patch details below.

Server-Side Request Forgery and Inclusion of Functionality from Untrusted Control Sphere in jsreport

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
0.00%1.12%2.25%3.37%0.4%2.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

22other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
jsreportnpm
2Kdownloads / week

Description

An unintended require and server-side request forgery vulnerabilities in jsreport version 2.5.0 and earlier allow attackers to execute arbitrary code.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmjsreportall versions2.6.0npm install jsreport@2.6.0

Affected Products

1 product · 1 configurations
Application
jsreportjsreport
≤ 2.5.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for jsreport, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update jsreport to 2.6.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-8128 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

An unintended require and server-side request forgery vulnerabilities in jsreport version 2.5.0 and earlier allow attackers to execute arbitrary code.
O3 Security · Impact-Aware SCA

Is CVE-2020-8128 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-8128: jsreport RCE — Fixed in 2.6.0