NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-7704 — linux-cmdline

CRITICALFix: piranna/linux-cmdline@53c61a8

CVE-2020-7704 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in linux-cmdline. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for linux-cmdline — see the affected versions and patch details below.

linux-cmdline is vulnerable to Prototype Pollution via the constructor

Also known asGHSA-2c29-wc65-4cx9SNYK-JS-LINUXCMDLINE-598674
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs86th percentile — riskier than 86% of all scored CVEsHighest risk
1.22%1.88%2.54%3.20%1.7%2.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

3other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
linux-cmdlinenpm
43downloads / week

Description

The package linux-cmdline is a parser for Linux kernel command line arguments. Versions before 1.0.1 are vulnerable to Prototype Pollution via the constructor.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmlinux-cmdlineall versions1.0.1npm install linux-cmdline@1.0.1

Affected Products

1 product · 1 configurations
Application
linux-cmdlinelinux-cmdline_project
< 1.0.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for linux-cmdline, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update linux-cmdline to 1.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7704 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package linux-cmdline is a parser for Linux kernel command line arguments. Versions before 1.0.1 are vulnerable to Prototype Pollution via the constructor.
O3 Security · Impact-Aware SCA

Is CVE-2020-7704 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-7704: linux-cmdline — Fixed in 1.0.1