CVE-2020-5203 is a critical-severity (CVSS 9.8) Improper Input Validation vulnerability in bcosca/fatfree. A fix is available for bcosca/fatfree — see the affected versions and patch details below.
Fat-Free Framework arbitrary code execution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
bcosca/fatfreeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Fat-Free Framework 3.7.1, attackers can achieve arbitrary code execution if developers choose to pass user controlled input (e.g., $_REQUEST, $_GET, or $_POST) to the framework's Clear method.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | bcosca/fatfree | all versions | 3.7.2composer require bcosca/fatfree:^3.7.2 |
Affected Products
fat-free frameworkfatfreeframeworkDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bcosca/fatfree, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update bcosca/fatfree to 3.7.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5203 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2020-5203 in your dependencies?
Find it across Packagist, including transitive dependencies.