NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

CVE-2020-5187 — DotNetNuke.Core

HIGH

CVE-2020-5187 is a high-severity (CVSS 8.8) Path Traversal vulnerability in DotNetNuke.Core. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for DotNetNuke.Core — see the affected versions and patch details below.

DNN Path Traversal via Zip Slip

Also known asGHSA-4qf5-7xc2-wqpg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.20%1.11%2.02%2.93%0.7%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
.NETDotNetNuke.Core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

DNN (formerly DotNetNuke) through 9.4.4 allows Path Traversal via unsafe handling of zip files

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetDotNetNuke.Coreall versions9.5.0dotnet add package DotNetNuke.Core --version 9.5.0

Affected Products

1 product · 1 configurations
Application
dotnetnukednnsoftware
≤ 9.4.4
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for DotNetNuke.Core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update DotNetNuke.Core to 9.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5187 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

DNN (formerly DotNetNuke) through 9.4.4 allows Path Traversal via unsafe handling of zip files
O3 Security · Impact-Aware SCA

Is CVE-2020-5187 in your dependencies?

Find it across NuGet, including transitive dependencies.

CVE-2020-5187: DotNetNuke — Fixed in 9.5.0