CVE-2020-36632 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in flat. A fix is available for flat — see the affected versions and patch details below.
flat vulnerable to Prototype Pollution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
flatnpmDescription
flat helps flatten/unflatten nested Javascript objects. A vulnerability, which was classified as critical, was found in hughsk flat up to 5.0.0. This affects the function unflatten of the file index.js. The manipulation leads to improperly controlled modification of object prototype attributes ('prototype pollution'). It is possible to initiate the attack remotely. Upgrading to version 5.0.1 can address this issue. The name of the patch is 20ef0ef55dfa028caddaedbcb33efbdb04d18e13. It is recommended to upgrade the affected component. The identifier VDB-216777 was assigned to this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | flat | all versions | 1.6.2npm install flat@1.6.2 |
| 📦npm | flat | ≥ 2.0.0&&< 2.0.2 | 2.0.2npm install flat@2.0.2 |
| 📦npm | flat | ≥ 3.0.0&&< 3.0.1 | 3.0.1npm install flat@3.0.1 |
| 📦npm | flat | ≥ 4.0.0&&< 4.0.2 | 4.0.2npm install flat@4.0.2 |
| 📦npm | flat | ≥ 5.0.0&&< 5.0.1 | 5.0.1npm install flat@5.0.1 |
Affected Products
flatflat_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update flat to 1.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-36632 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-36632 in your dependencies?
Find it across npm, including transitive dependencies.