NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2020-35381 — jsonparser

HIGHFix: buger/jsonparser#221

CVE-2020-35381 is a high-severity (CVSS 7.5) vulnerability in github.com/buger/jsonparser. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/buger/jsonparser — see the affected versions and patch details below.

Denial of Service in jsonparser

Also known asGHSA-8vrw-m3j9-j27cGO-2021-0057
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.98%1.95%2.93%0.2%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/buger/jsonparser

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

jsonparser 1.0.0 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a GET call.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/buger/jsonparserall versions1.1.1go get github.com/buger/jsonparser@v1.1.1

Affected Products

2 products · 3 configurations
OS
fedorafedoraproject
2 versions
3233
Application
jsonparserjsonparser_project
1 version
1.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/buger/jsonparser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/buger/jsonparser to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-35381 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

jsonparser 1.0.0 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a GET call.
O3 Security · Impact-Aware SCA

Is CVE-2020-35381 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2020-35381: jsonparser DoS — Fixed in 1.1.1