NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
HIGH severity

CVE-2020-10675 — jsonparser

HIGHFix: buger/jsonparser#192

CVE-2020-10675 is a high-severity (CVSS 7.5) CWE-835 vulnerability in github.com/buger/jsonparser. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/buger/jsonparser — see the affected versions and patch details below.

Infinite Loop in jsonparser

Also known asGHSA-rmh2-65xw-9m6qGO-2021-0089
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.00%1.09%2.18%3.28%0.3%2.6%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/buger/jsonparser

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

The Library API in buger jsonparser through 2019-12-04 allows attackers to cause a denial of service (infinite loop) via a Delete call.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/buger/jsonparserall versions1.0.0go get github.com/buger/jsonparser@v1.0.0

Affected Products

2 products · 3 configurations
OS
fedorafedoraproject
2 versions
3132
Application
jsonparserjsonparser_project
< 1.0.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/buger/jsonparser, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/buger/jsonparser to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-10675 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

The Library API in buger jsonparser through 2019-12-04 allows attackers to cause a denial of service (infinite loop) via a Delete call.
O3 Security · Impact-Aware SCA

Is CVE-2020-10675 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2020-10675: jsonparser DoS — Fixed in 1.0.0