CVE-2020-35305 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in gollum. A fix is available for gollum — see the affected versions and patch details below.
Gollum Cross-site Scripting vulnerability via filename parameter to New Page dialog
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
gollumReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Cross site scripting (XSS) in gollum 5.0 to 5.1.2 via the filename parameter to the 'New Page' dialog.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | gollum | ≥ 5.0&&< 5.1.2 | 5.1.2bundle update gollum --conservative |
Affected Products
gollumgollum_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for gollum, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update gollum to 5.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-35305 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-35305 in your dependencies?
Find it across RubyGems, including transitive dependencies.